RCom PBX & Core Infrastructure Maintenance

Completed
Scheduled for February 25, 2024 at 11:00:00 AM – 4:00:00 PM

Affects

RCom Unified Communications Hosted PBX Instances
RVoice Telecom Service
Emergency / 911 Call Routing
International Calling
Origination (Inbound) Calling
Termination (Outbound) Calling
Updates
  • Completed
    February 25, 2024 at 4:00:00 PM
    Completed
    February 25, 2024 at 4:00:00 PM
    Maintenance has completed successfully
  • Update
    February 25, 2024 at 2:03:48 PM
    In progress
    February 25, 2024 at 2:03:48 PM

    We have completed the billing updates on identified customer PBX instances and aggregation hosts where necessary. Maintenance was not performed on all customer PBX instances during this maintenance window due to some internal issues identified within our virtualization platform that hindered our team's automated workflows and backup <-> rollback procedure.

    We will schedule future maintenance on the remaining systems in the coming weeks.

  • In progress
    February 25, 2024 at 11:00:01 AM
    In progress
    February 25, 2024 at 11:00:01 AM
    Maintenance is now in progress
  • Planned
    February 25, 2024 at 11:00:00 AM
    Planned
    February 25, 2024 at 11:00:00 AM

    Rival5 will be staging and completing software upgrades across our core PBX infrastructure on Sunday, February 25, 2024 beginning at 05:00 AM Central Time, through Sunday, February 25, 2024 at 10:00 AM Central Time. This maintenance window will be used to update system infrastructure, core computing systems, and PBX software across our platforms. An identified bug in our internal reporting and processing workflows has caused some billing inconsistencies with totaling extension counts in some areas. This has been fixed with intermediate builds within respective software branches and will be wrapped up within this maintenance window.

    A "rolling update" approach will be utilized to minimize the prolonged impact on customer instances and call operations during this time. During this maintenance window, there will be a brief period of downtime where devices and endpoints will unregister from our networks until our services are again available. We will do our best to mitigate any call drops and adverse effects to operations while performing this maintenance. We will view and consider live system activity before this downtime takes place.

    We expect no widespread impact on overall network health and service stability, but we will monitor and test our work every step of the way.  If your organization's operations conflict with this scheduled timeframe, we may contact you directly with an alternate individual maintenance window.

    Don't hesitate to get in touch with us using our Rival5 Support Center for any questions about this maintenance notification or should you experience any adverse consequences after this maintenance is completed.